Questions & Answers

how do I program RF642W fobs to work on Evo-one?

0 votes
i have installed an Evo-one on my 2019 mazda cx5 and the OEM key fob 3x lock start is working fine. I have also included the RF642W when i programmed / flashed the module. I am not sure what to do next to make the rf kit functioning.  i am a bit confused with the quick guide. I dont get the same response from the system (as stated on the guide) when trying to do the steps on programming the fobs. not sure what I am missing.
asked 5 days ago in Mazda by Neil Bryan Sanchez (130 points)

2 Answers

+1 vote
HI....... I had problems as well. Turns out i was programming it for a evo all. After speaking to a tech at Fortin i corrected it buy STEP 1 turning the ignition on STEP 2  TURN ignition off  STEP 3 turn the ignition on the LED will be on. STEP 4  press the brake pedal four times LED will flash rapidly STEP 5 on each tramsmitter PRESS AND RELEASE the minus button once and the the lock button . (make sure to do each remotes) minus button first ......lock button second . the LED will stop flashing confirming programming. STEP 6  turn ofF the ignition to exit programming.  I hope that helps you.  ALOHA
answered 5 days ago by Raymond wiley (230 points)
+1 vote

I have always had more luck using the valet switch,  

1. turn ignition to run

2. press and hold the valet switch (led will flash/horn will honk)   

3.  press the valet switch 5 times  (horn will honk/light will flash with each press)

4. press and release the brake pedal once  (led will flash rapidly)

5 press the - button and then the lock button on each remote ( led will stop flashing to comfirm programing

6. turn ignition off to exit programing

7. test it :)

https://cdn02.fortin.ca/download/33021/rf642w-install-guide-33021.pdf

 

answered 4 days ago by ken simpson (900 points)
...